Gimp

Da EigenWiki.

Storia

Nasce come tesina semestrale di Spencer Kimball e Peter Mattis per un corso per l'Università della California, Berkeley nel 1995. Associazione studentesca a Berkeley. A seguito venne chiamato GIMP, acronimo per GNU Image Manipulation Program, ed inserito nel progetto GNU.

Cos’è GIMP

GIMP è un programma di manipolazione di immagini raster o bitmap, cioè di files fatti da una matrice bidimensionale di pixel colorati con combinazioni dei singoli canali (ad es. RedGreenBlue per i jpeg e RedGreenBlueAlfa per i png) che hanno un range di 256 valori per canale. GIMP è multipiattaforma, multilingua, multietnico e multirazziale oltre ad essere software libero rilasciato sotto licenza GPLv2. È sviluppato da GNOME ed è scritto in C.

Installazione

È possibile scaricare l’ultima versione di GIMP dal portale ufficiale.

Caratteristiche

Interfaccia

L’interfaccia, dalla versione 2.8.* in poi, oltre alla visualizzazione classica con le tre finestre

  • strumenti
  • immagine
  • livelli

viene già con la modalità finestra singola (single window mode) attivabile da

Finestra -> Modalità finestra singola 
Window -> Single window mode

che è sostanzialmente divisa in cinque parti:

  • Alto a sinistra -> griglia con le icone degli strumenti
  • Basso a sinistra -> opzioni dello strumento selezionato
  • Centro -> anteprima dell’immagine
  • Alto a destra -> livelli/canali/tracciati
  • Basso a destra -> pennelli/motivi/gradienti

Formati supportati

GIMP sopporta l'importazione e l'esportazione di un gran numero di formati di file differenti,[elenco formati supportati] mentre l'XCF, ne rappresenta il formato nativo, utilizzato per immagazzinare i dati relativi all'immagine.

Formati dei file
Importati ed esportati GIMP dispone di supporto per importare ed esportare formati d'immagine come BMP, JPEG, PNG, GIF e TIFF, insieme ai formati di file di svariate altre applicazioni, come le animazioni flic della Autodesk, le immagini di Paint Shop Pro e documenti di Photoshop. È dotato di supporto per documenti PostScript, bitmap X e Zsoft PCX. GIMP può elaborare anche i dati della path da file SVG, come pure i files ICO, delle immagini per le icone adottate da Windows.
Importati GIMP può importare documenti PDF Adobe ed il formato Raw, impiegato da molte fotocamere digitali, ma non può salvare in questi formati. Un plug-in, UFRaw, open source vi aggiunge piena compatibilità, e sembra essere più veloce di Adobe, aggiornandosi ai nuovi modelli di fotocamera.
Esportati GIMP può esportare file d'immagine MNG (nella versione GNU/Linux) ed HTML, files codice sorgente C ed, usando un apposito plug-in, ASCII art.

Funzionalità

(da documentare)

Breve introduzione all’uso e tecniche semplici

Nuova immagine

File -> Nuova (Ctrl + N) Sembra un passo molto banale ed invece è questo l’inizio del tutto! Appare una finestra con scritto:

  • Modelli

I modelli sono tra i più comuni (A3, A4, A5, etc.) e bisogna scegliere quello più opportuno. N. B. È importante tenere conto della ppi (pixels per inch) del proprio schermo, cioè: gli schermi solitamente non hanno ppi troppo elevate (sicuramente inferiore a quello della stampa che si aggira sopra i 200dpi, dots per inch), infatti spesso succede che files impostati con modello ad es. A4 vengano fuori più “piccoli” di un “vero” A4 al momento della stampa (bisogna infatti stare attenti alla dpi anche all’esportazione), quindi è consiglio vivissimo se si vuole fare un A4 fare il lavoro su un modello A3, così anche per gli altri modelli: usare il successivo, in dimensioni, a quello che si desidera usare.

  • Larghezza ed altezza (unità di misura)

Qualora servisse qualcosa con misure ben precise allora è utile usare manualmente le opzioni di larghezza ed altezza con l’unità di misura che serve.

  • Orientazione immagine

Orizzontale o verticale.

  • Opzioni avanzate

ppi X e ppi Y, spazio di colore, riempimento e commento. Riempimento solitamente è del colore di sfondo (Bianco di default), ma qualora servisse può essere utile selezionarlo manualmente (ad es. usare il trasparente come sfondo).

Livelli

In GIMP è molto importante capire l’essenza dei livelli, perché per la natura raster (bitmap) del programma è molto utile avere più livelli (anche qualcuno più del necessario).


Guida agli strumenti

in ordine di colonne e righe nella griglia:

Strumenti di selezione

  • Rettangolare (R)

seleziona dei semplici rettangoli, ridimensionabili agli angoli ed ai lati, e trascinabili al centro.

  • Ellittica (E)

seleziona delle semplici ellissi, ridimensionabili agli angoli ed ai lati, e trascinabili al centro.

  • A mano libera (F)
  • Fuzzy (U)

seleziona usando una soglia (la cui sensibilità è regolabile nelle opzioni strumento) in modo pseudo-intelligente.

  • Per colore (Maiusc + O)
  • Forbici intelligenti (I - i maiuscola)
  • Primo piano

Opzioni comuni strumenti selezione:

  • Modalità: rimpiazza, unisce, sottrae ed interseca ciò che si sta per selezionare con ciò che era selezionato un attimo prima.

Scorciatoie (Seleziona -> _):

  • Ctrl + A -> Seleziona tutto
  • Ctrl + Maiusc + A -> deseleziona tutto (si può anche fare doppio click sull’immagine con la modalità ‘’rimpiazza’’)
  • Ctrl + I -> Inverti selezione

Tracciati

Crea dei tracciati con curve.

  • Scorciatoia da tastiera: B.

Prelievo colore

Preleva il colore del pixel clickato e lo copia nel colore in primo piano (nero di default); se fatto con il pulsante Alt premuto fa lo stesso ma lo copia nel colore di sfondo (bianco di default).

  • Scorciatoia da tastiera: O.

Zoom

Scorciatoia da tastiera: Z. N. B. Spesso è più comodo usare Ctrl + RotellinaMouse per aumentare/diminuire lo zoom perché molto più adattabile alle esigenze del momento. Per cronaca è bene dire che è presente anche un’indicatore dello zoom attuale in basso nella parte centrale (attraverso cui si può modificare lo zoom attuale con pochi preset già presenti).

Misurino

In genere uno strumento non necessario a meno che non si debbano fare cose abbastanza precise dove la simmetria è molto importante.

  • Scorciatoia da tastiera: Maiusc + M.

Muovi

Non smetterai mai di usarlo, è necessario per ‘’acchiappare’’ qualcosa e spostarlo sul “foglio” di lavoro.

  • Scorciatoia da tastiera: M.

Allinea

Utilissimo strumento per allineare un livello in modo preciso (ad es. centrare un logo).

  • Scorciatoia da tastiera: Q.

Trasformazioni

  • Ritaglia (Maiusc + C)
  • Ruota (Maiusc + R)

Clickando sul livello apparirà una finestra in cui è possibile regolare in modo preciso l’angolatura, altrimenti basta immaginare di avere un perno centrale ed usare il cursore per fare ‘’fisicamente’’ ruotare il livello. È possibile spostare il livello trascinandolo clickando al centro di esso.

  • Scala (Maiusc + T)

Clickando sul livello apparirà una finestra in cui è possibile regolare in modo preciso le dimensioni del livello, di default hanno le proporzioni bloccate (avviene un ridimensionamento lungo la diagonale) ma è possibile sbloccarle cliccando sulla catenina a fianco dei valori in px. È possibile fare il ridimensionamento anche solo clickando ai lati o agli angoli del livello (appariranno delle forme guida).

  • Inclina (Maiusc + S)

Serve ad inclinare l’immagine su uno degli assi.

  • Prospettiva (Maiusc + P)

Serve a dare l’illusione prospettica al livello.

  • Rifletti (Maiusc + F)

Serve solo a riflettere orizzontalmente o verticalmente il livello.

Testo

Lo strumento di testo è ben fatto ed abbastanza completo. Basta clickare facendo una selezione che si desidera usare per scrivere il testo ed automaticamente comparirà ad uno degli angoli di questo rettangolo selezionato (che si ridimensiona come ogni altra selezione di GIMP) un menù con Font, dimensioni colore, opzioni del carattere (grassetto, corsivo, sottolineato e barrato) spaziatura tra le lettere. Ricorda che i testi sono dei livelli a sé (che saranno nominati con il contenuto del testo), quindi potrai modificarli e spostarli a tuo piacimento anche dopo averlo creato, persino dopo aver applicato alcune trasformazioni; però qualora applicassi un filtro ti verrà chiesto che è necessario annullare l’operazione del filtro per modificare il testo. Nelle opzioni dello strumento sono presenti le stesse ed anche più opzioni del menù che compare nella casella di testo selezionata.

N. B. Se installi un nuovo font, lo troverai nella lista solo al riavvio di GIMP.

  • Scorciatoia da tastiera: T.

Riempimento

Il classico riempimento: click ricopre tutto ciò che trova con colore uguale (sotto una certa soglia, regolabile nelle opzioni strumento standard a 15) con il colore in primo piano (o in sfondo se tenete premuto Ctrl). È possibile anche riempire con motivi (molti sono già forniti di base).

Scorciatoia da tastiera: Maiusc + B.

Gradiente

Crea un gradiente che ricopre tutta la selezione.

Opzioni strumento:

  • Modalità
  • Opacità
  • Gradiente

Selezionare il gradiente, quello standard è Colore di primo piano -> Colore di sfondo.

  • Forma lineare, conica, etc. .
  • Scorciatoia da tastiera: L.

Strumenti di colorazione

  • Matita

Scorciatoia da tastiera: M.

  • Pennello

Scorciatoia da tastiera: P.

  • Gomma

Scorciatoia da tastiera: Maiusc + E.

  • Aerografo

la differenza con i precenenti è che l’aerografo colora pian piano in modo graduale, immaginatelo come una bomboletta spray. Scorciatoia da tastiera: A.

Sono strumenti simili e fanno le cose che ci si aspetta dai nomi. Opzioni strumento:

  • Modalità
  • Opacità
  • Pennello: selezione del pennello (standard, con sfumatura radiale, rotondo)
  • Dimensione
  • Rapporto dimensioni: 0 -> dimensioni rispettate, altrimenti viene schiacchiato il pennello in uso.
  • Angolo: ruota il pennello dello strumento in uso.

N. B. È molto importante far notare che una volta fatto un qualsiasi segno con gli strumenti precedenti viene ‘’definitivamente’’ colorato il livello su cui si sta lavorando, quindi per tornare indietro l’unico modo è Ctrl + Z (annulla)! Ed è molto importante ricordarsi che il numero di annulla è limitato, quindi meglio fare ‘’pennellate’’ il più uniformi e continue possibile, così da potersi permettere più annulla.

Stilo

È un pennello all’n-esima potenza, è personalizzabilissimo!

  • Scorciatoia da tastiera: K.

Clona

  • Regolare

Si seleziona l’area ‘’sorgente’’ con: Ctrl + Click, e si clona poi come se fosse un vero e proprio pennello (quindi si può selezionare anche un pennello personalizzato) e vedrete una forma muoversi assieme al mouse mentre clickate partendo dal punto sorgente che avete selezionato, che ti farà capire cosa stai clonando in quel momento.

  • In prospettiva

Lo strumento di prima fatto in prospettiva.

Le opzioni sono le stesse degli strumenti di colorazione.

  • Scorciatoia da tastiera: C.

Cerotto

Ripara le irregolarità dell’immagine.

  • Scorciatoia da tastiera: H.

Sfoca/Contrasta

Fa esattamente quello che ci si aspetta dal nome ed ha le stesse opzioni degli strumenti di colorazione.

N. B. Talvolta ‘’sembra non funzionare’’ in realtà è semplicemente non troppo evidente, quindi tranquilli, sta sfocando e contrastando!

Scorciatoia da tastiera: Maiusc + U. (+Alt per Contrasta)

Sfumino

Immaginate di scrivere un segno col gessetto (o carboncino) su una lavagna (od un foglio) e poi passarci il dito, bene quello è l’effetto dello sfumino sul vostro livello. Le opzioni sono le stesse degli strumenti di colorazione.

  • Scorciatoia da tastiera: S.

Scherma/Brucia

Uno strumento molto utile per schiarire o scurire il livello, con una specie di pennello ‘’magico’’ che fa proprio questo. Le opzioni sono le stesse degli strumenti di colorazione e funziona come il pennello con in più:

  • Tipo (Ctrl): Scherma (schiarisci) e brucia (scurisci).
  • Campo: Ombre (le parti più scure dell’immagine), Mezzi toni (i toni medi di luminosità) e Alteluci (le parti più chiare)
  • Esposizione: decide l’ammontare dell’effetto.
  • Scorciatoia da tastiera: Maiusc + D.

Gabbia

(da documentare, tanto non serve!)

  • Scorciatoia da tastiera: Maiusc + G.

Menù

Immagine

  • Duplica
  • Modalità
  • Trasforma (rotazioni e riflessioni)
  • Dimensione superficie
  • Dimensione di stampa
  • Scala immagine: N. B. scala TUTTA l’immagine, quindi anche i singoli livelli, e non è sempre una operazione reversibile che conserva la qualità dell’immagine.
  • Ritaglia alla selezione: ritaglia TUTTA l’immagine, quindi anche i singoli livelli, e non è una operazione reversibile poi certe cose potresti perderle!
  • Autoritaglio immagine: cerca di togliere ai margini ed ottimizzare l’immagine se sono presenti trasparenze inutilizzate.
  • Ritaglio preciso
  • Fonde i livelli visibili: unisce TUTTI i livelli visibili, non è una operazione reversibile. Ad esempio, una volta fuso un logo con una foto nello sfondo non potrai più modificare il singolo logo (anche un semplice ridimensionamento).
  • Appiattisce immagine: simile a sopra, semplicemente unisce TUTTI i livelli, anche non visibile
  • Guide: può essere utile per orientarsi nell’immagine, con simmetrie e misure.

Livello

  • Nuovo livello

Scorciatoia da tastiera: Maiusc + Ctrl + N. Oppure nel pannello a destra c’è il pulsante “nuovo livello”.

  • Nuovo gruppo di livello
  • Duplica livello

Scorciatoia da tastiera: Maiusc + Ctrl + D. Oppure facendo click destro sul livello a destra e poi duplica.

  • Elimina livello
  • Pila
  • Maschera
  • Trasparenza:

-Aggiungi canale alfa: rende una immagine RGB in RGBA, necessario se si vuole usare la trasparenza.

-Rimuovi canale alfa: duale del precedente.

-Colore ad alfa: utilissimo se si vuole rendere ogni combinazione RGB di quel colore totalmente trasparente. Ad esempio immaginate gli effetti speciali nei film; viene usato il verde acido e non si vestono mai di verde, perché fanno proprio questo, frame per frame! Decidono che una data combinazione di RGB diventa totalmente trasparente, così poi possono mettere quel che vogliono mantenendo le cose non verdi.

  • Trasforma: trasforma il singolo livello, esattamente identico come opzioni a quello presente in Immagine.

Colori

  • Bilanciamento colore

Permette la regolazione di ombre, mezzitoni e alteluci nelle tre componenti RGB.

  • Tonalità-saturazione

Permette di regolare Tonalità, luminosità e saturazione.

  • Colora

Colora l’immagine facendo questo: prima la trasforma in B/N e poi fa diventare le tonalità di grigio monocromatiche con il colore appena scelto (selezionabile modificandone tonalità, saturazione e luminosità), può sembrare complesso ma l’anteprima immediata aiuta a capire bene cosa sta succedendo.

  • Luminosità-contrasto

Quello che ci si aspetta.

  • Soglia

Fa diventare l’immagine bicromatica solo bianco e nero e si può regolare il punto di metà luminosità.

  • Livelli

Permette di definire il punto di luminosità media, massima e minima. Così può sembrare poco chiaro, ma è sempre utile la funzione di anteprima in tempo reale, sperimentate!

  • Curve

Stare lì a spiegare è complicato ed inutile, muovetelo un po’ e vedrete in tempo reale cosa fa! Consiglio: cercate sempre di fare una curva che sia una funzione, e magari non strana come andamento, sennò rischia di esserci qualche problema cromatico.

  • Posterizza

Rende un particolare effetto poster, ed in tempo reale, potrete cambiare il numero di colori a cui verrà “appiattita” l’immagine

  • Desaturazione

Rende l’immagine in B/N con tre possibili modi, usare quello migliore di volta in volta.

  • Inverti/inverti valore

Inverte i colori o inverte i valori (cioè inverte il punto di bianco con il punto di nero, ma i colori rimangono invariati).

Filtri

(da documentare)

Spazio di colore

(da documentare)